Cloud Storage Box is experiencing an outage
Incident Report for Fast Technologies
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 27, 2017 - 22:30 UTC
Monitoring
A number of API's are experiencing degraded performance which is affecting Fast.io functionality for servers tied to box.
Posted over 1 year ago. Oct 27, 2017 - 21:04 UTC